昨晚想要用手机做网站服务器,遂在android下用ksweb直接跑lnmp。

但在安装nextcloud时,它告诉我系统中没有它支持的任何一种语言。因为lnmp直接在安卓上运行,故安装可以被其识别的语言是很麻烦的(不可行),然后我在google里找到了注释掉检测语言代吗的解决方案,不过新版nextcloud并不存在那个文件。

我以错误提示的英文在github上的nextcloud项目中搜索,找到了文件所在位置,然后成功注释掉这段代码。但是安装步骤完成后,打开网站还是显示Server Internal Error。我翻找lighthttpd的日志,没有发现有用的信息,故暂时搁置。